Requesting Wordpress help!

I just started setting up my wordpress site and ran into a massive problem that hours of google research didn't solve: Those dreadful "continue reading" links of the twenty ten theme. I want to get rid of them, but the only solution I figured out through online research is by editing the php file. Seeing as I'm not self hosting (and would prefer not to), that isn't an option.


I've tried out other themes, but there is another problem with all of them: They cut large chunks from my serial's banner. I'd really like for the whole thing to be visible, it's not finished yet, but I think it's too pretty to be mutilated! Only the twenty ten theme shows the whole thing.


For a visual impression (please don't laugh at how unfinished it is): http://anathemaserial.wordpress.com


Does anyone know a solution, either to deactivate those irritating "continue reading" links from twenty ten, or to convince another theme to show my whole banner?


Thanks much! <3


Edit to add: Suggestions of not-free themes that would show the entire banner and are decently set up for serials would be appreciated as well.


What I did to fix this.

First I made a 'Home' and a 'Latest Post' page.

Then I went to the dashboard > appearance > Customize

I clicked Front

Front page displays a static page.

I set the Front page to 'Home' and the post page to 'Latest Post'


I am using the 'Suits' theme so I don't know if it will work for 2010.


My front page looks like this (http://taulsn.wordpress.com/) and doesn't change. My latest post page looks like this (http://taulsn.wordpress.com/latest-post/) and updates automatically.


Hope that helps.


(If this wasn't blatant self advertising on my part I don't know what is, but I can totally justify it.)


I don't have a theme in mind that can do both of the things you want. The "Read more" is a theme dependent feature. The theme "Suits" at online-novel.com (theonlinenovel.wordpress.com) allows you to switch the Read more on if needed but defaults to it being off. however, there is no custom header option.


Not sure if you already used the *.com search functions but when searching through themes, the option you want for your own header is the "flexible header" and/or "custom header" feature: http://theme.wordpress.com/themes/features/flexible-header+custom-header/


Some themes just auto-clip the posts because it's kind of considered bothersome to see a wall of text. One workaround to consider, don't put your installments into posts. Rather, put them into pages and link your page to your newest "post."


That's what I'm doing on my wordpress.org site (Tales, link below) with Weaver II. I picked Weaver II for customizable headers (and multiple banners) as well as two menus.


If you still want to try it with posts, try posting a question in the WP.com forums at http://en.forums.wordpress.com/. You will have to tell them what theme you've tried and ask for suggestions for new ones. You may, however, be told that the two features you want together are going to be hard to do on the *.com site.


Issue solved!


I somehow didn't realize that some themes support a "flexible header" option, or how to get it to work. For some reason, even after adjusting image width with CSS, Wordpress insisted on still cropping the header. However, as I belatedly found out, it is possible to "skip" the cropping.


I've toyed around with the twenty eleven theme, but switched to misty lake because that one supports a sidebar widget for every page. The default green title is a bit of a bother, but oh well.


I wish they had a tiny bit more customization on the themes (I was stuck with Orange for my title/links... I took it to heart and ran with it)


One great way to give your site a little character is go all out on the background. Make it static so it doesn't move, then you can make things look fancy.


eg http://agreyworld.wordpress.com/2013/02/06/chapter-1-01/


The paint splats behind the menu items, along with the title etc are all just in the background image.


Thanks Grey, my background definitely needs work. What do you mean with 'so it doesn't move', though? So it's just one large picture rather than several repetitions of the theme bordering each other? I'll have to look into deactivating those extra phantom images. Or maybe it's a question of overall image size? Hmmm.


Wow, nice banner


On Appearance > Background, select:


Position: Center (Assuming your theme places itself in the center, with space either side. Most will I assume)


Repeat: No Repeat (This prevents it looping if you scroll down enough. You will have to have your background image on/fade to the actual solid background colour you are using, in my case, black)


Attachment: Scroll. (This makes it so the background image so it scrolls with the page, i.e. 'staying' with the other things like the title. "Fixed" makes it so the background follows you as you scroll about the page. Both of these options are pretty confusingly/ambiguously worded though. I thought they were the other way around)


With those three options your background can interact with the title/page pretty easily with some trial and error. When I first started I had the character sitting with her's legs dangling off the side of the book.


I use the constructor theme, i've never had an issue.


However, the read more is an option in base theme. You dont have to have it turned on. ill llok when i get home and find that switch for you!


Could anyone tell me how to convince the "previous chapter" and "next chapter" links to stay on the same line? No matter what I do, "next chapter" always slips to a lower line, giving the site a lopsided look. I've tried align left, align right, align center with spaces between the two links. Nothing works.


Could this be a theme related issue?


Each line is aligned the same way, no matter what. It's just the way things are. So, here's a Duck tape solution:

1. Center align the line

2. Type Previous Chapter with a space and hyperlink it

3. Hold down the Shift key and press the backslash button, putting a space after it

4. Type Next Chapter and hyperlink it


It's a crude method, but it will work.


Do you have access to the HTML? To the CSS? Or is this stuff hand-entered as part of the text? At the moment, you are using a whole string of non-breaking spaces to force the previous and next links to fill the width of the page, which simply will not work reliably.


Let me know how much access you have, and I should be able to help you get something working.


Thanks, alex and Chris!


I'm not self hosting, but... I think I have access to the HTML by clicking on the "text" tab instead of visual. If there's another form of access, I don't have it. I can't view the full CSS stylesheet, but supposedly (never tried it) I can overwrite some portions of it by writing into the CSS revisions window under appearance -> customize -> CSS.


Do you see the next and previous links in the HTML you can edit?


Looks like it. I was going to copy paste, but then realized the forum formats the code like Wordpress does.


Okay, then try this:


<p style="float: right;"><a href="URL HERE">next</a></p><p style="float: left;"><a href="URL HERE">previous</a></p><p style="clear: both;"></p>


You'll want to put in correct URLs, of course.


It worked! Thanks, Chris. <3


Glad to hear it. Would have been very embarrassing if it hadn't. :)


I don't know how useful this might be to you, but I simply place prior and next chapter links in the body of each post, completely bypassing the theme restrictions.


I posted a video on how to do it to Youtube. Once you do it once, it's mousework, and takes only a few seconds per chapter.


https://www.youtube.com/watch?v=HuYuGqRA5cg&feature=youtu.be