Unable to Post Review

I finally finished my review of Existential Terror and Breakfast but now when I attempt to save it, I am directed to a 403 page.


"Forbidden

You don't have permission to access /wp-content/plugins/webfictionguide/control.php on this server."


I tried several things but kept receiving this message. Has anyone else had this problem?


I've had this happen a few times. I've generally needed to make the review shorter, then it goes through without issue.


I tried shortening the review to just the words 'test', and that worked. But the review double posted itself, strangely. I have deleted it. If there is a character limit, I wish I knew what it was. I did a test and Rhythm's review, for instance, has a higher character count than mine, and is posted. So I hate to simply keep trimming.


Does it have something to do with random things like page breaks or backslashes or other strange characters?


No strange characters. I tend to use a lot of paragraph breaks, so I tried minimizing those, in case the text came out being too long, but still to no avail. I'm at a loss.


Review is posted but had to be considerably trimmed, unfortunately. It's as long as I could get it.